当前位置 博文首页 > 文章内容

    ACM题目 1083: Hello, world!

    作者: 栏目:未分类 时间:2020-09-07 15:01:57

    本站于2023年9月4日。收到“大连君*****咨询有限公司”通知
    说我们IIS7站长博客,有一篇博文用了他们的图片。
    要求我们给他们一张图片6000元。要不然法院告我们

    为避免不必要的麻烦,IIS7站长博客,全站内容图片下架、并积极应诉
    博文内容全部不再显示,请需要相关资讯的站长朋友到必应搜索。谢谢!

    另祝:版权碰瓷诈骗团伙,早日弃暗投明。

    相关新闻:借版权之名、行诈骗之实,周某因犯诈骗罪被判处有期徒刑十一年六个月

    叹!百花齐放的时代,渐行渐远!



    题目描述:

    This is the first problem for test. Since all we know the ASCII code, your job is simple: Input numbers and output corresponding messages.

    输入:

    The input will contain a list of positive integers separated by whitespaces(spaces, newlines, TABs). Please process to the end of file (EOF). The integers will be no less than 32.

    输出:

    Output the corresponding message. Note there is NOT a newline character in the end of output.

    样例输入:

    72 101 108 108 111 44
    32 119 111 114 108 100 33

    样例输出:

    Hello, world!

    思路:

    将所有数字存放到一个数组中

    然后对数组中每一个数字取整数输出

    代码:

    #include<stdio.h>
    int main()
    {
        char c;
        int a[100],i=0;
        while((scanf("%d",&a[i]))!=EOF)
        {
            i++;
        }
        for(int j=0;j<i;j++)
            printf("%c",a[j]);
        return 0;
    }