当前位置 博文首页 > 文章内容

    Selection sort in Java Max-min sorting

    作者: 栏目:未分类 时间:2020-08-15 9:00:18

    本站于2023年9月4日。收到“大连君*****咨询有限公司”通知
    说我们IIS7站长博客,有一篇博文用了他们的图片。
    要求我们给他们一张图片6000元。要不然法院告我们

    为避免不必要的麻烦,IIS7站长博客,全站内容图片下架、并积极应诉
    博文内容全部不再显示,请需要相关资讯的站长朋友到必应搜索。谢谢!

    另祝:版权碰瓷诈骗团伙,早日弃暗投明。

    相关新闻:借版权之名、行诈骗之实,周某因犯诈骗罪被判处有期徒刑十一年六个月

    叹!百花齐放的时代,渐行渐远!



    Let's say that an array is max-min sorted if the first element of the array is the maximum element, the second is the minimum, the third is the second maximum and so on. Modify Selection sort such that it can be used for max-min sorting.

    Input: the first line contains a number nn — the length of an input array. The next line contains nn numbers — the elements of the array.

    Output: a max-min sorted input array.

    Sample Input 1:

    5
    1 2 3 4 5
    

    Sample Output 1:

    5 1 4 2 3
    

    Sample Input 2:

    6
    3 1 2 5 4 7
    

    Sample Output 2:

    7 1 5 2 4 3
    
    import java.util.Arrays;
    import java.util.Scanner;
    
    public class Main {
        public static void main(String[] args) {
            Scanner scanner = new Scanner(System.in);
            int n = Integer.parseInt(scanner.nextLine());
            int[] array = Arrays.stream(scanner.nextLine().split("\\s+"))
                .limit(n)
                .mapToInt(Integer :: parseInt)
                .toArray();
            Arrays.stream(selectionSort(array)).forEach(i -> System.out.print(i + " "));
        }
    
        private static int[] selectionSort(int[] array) {
    
            boolean forMax = true;
            for (int i = 0; i < array.length - 1; i++) {
                int index = i;
                for (int j = i + 1; j < array.length; j++) {
                    if (forMax ? array[index] < array[j] : array[index] > array[j]) {
                        index = j;
                    }
                }
                forMax = !forMax;
                int temp = array[index];
                array[index] = array[i];
                array[i] = temp;
    
            }
            return array;
        }
    }